Installation Guide

If you have trouble with PHC you can ask and hope for help here.
the-fallen
Administrator
Posts: 346
Joined: Wed 9. Jul 2008, 19:57

Re: Installation Guide

Post by the-fallen » Sat 2. Aug 2008, 11:52

What kernel are you exactly using? What kernel-sources are you using when compiling the module?

If you want to replace the distribution shipped kernel module with a patched one then you also need to use the distributions kertnel sources for that. Most times you can not mix up distri-kernels and vanilla-kernels.

Radius
Posts: 1
Joined: Sat 2. Aug 2008, 00:25

Re: Installation Guide

Post by Radius » Sat 2. Aug 2008, 17:48

song1980 wrote:Hi,the-fallen, sorry to bother you again and again, so far I unload the speedstep_centrino module and load the acpi-cpufreq module, and I find some files beginning with phc_, but I can't read any value from phc_controls :oops:

Code: Select all

 cat phc_controls
cat: phc_controls: no such device

same problem, files are there, but I can' t nothing to read

kernel 2.6.24-19 (standard distro core)
ubuntu 8.04 64bit
Intel C2D T7300
FSC Esprimo mobile D9500

and next question is, where can I download phctool? I can' t see it here.

thanks for advice

the-fallen
Administrator
Posts: 346
Joined: Wed 9. Jul 2008, 19:57

Re: Installation Guide

Post by the-fallen » Sun 3. Aug 2008, 09:42

same problem, files are there, but I can' t nothing to read
So there is NOTHING to read or is there something like "No such device." to read?
Strange. Never seen this problem with a Core2Duo CPU.


I'll upload PHCTool soon, I've just forgotten it. ;)

Dichter_als_Goethe
Posts: 1
Joined: Wed 27. Aug 2008, 20:43

Re: Installation Guide

Post by Dichter_als_Goethe » Wed 27. Aug 2008, 20:53

neverdie wrote:Another problem here....
I'm compiling kernel 2.6.26 and I have linux-phc-0.3.2-kernel-vanilla-2.6.26.
Patching looks successful, the module compiles without errors, I unload the current acpi_cpufreq module, but when I try to load the new one I get this:
root@xxxxxx:/usr/src/linux-2.6.26# insmod arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko
insmod: error inserting 'arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko': -1 Invalid module format
Any ideas?
its teh same thing on my mashine.
I Have Debian on an Aspire One (Intel Atom)
Installed Kernel is 2.6.26-1 from sid
installed kernel-source is 2.6.26-3 from sid (should be the right one maybe i try with 2.6.26-1 to morrow)
I used the debian kernel-config

the-fallen
Administrator
Posts: 346
Joined: Wed 9. Jul 2008, 19:57

Re: Installation Guide

Post by the-fallen » Thu 28. Aug 2008, 17:04

Thanks for the hint.

I will try to find out how to set up values to the intel ATOM CPU. But I do not own one (even if I think they are interesting).

martini
Posts: 3
Joined: Fri 29. Aug 2008, 15:32

Re: Installation Guide

Post by martini » Fri 29. Aug 2008, 15:45

i`d love to use that tool too, but I'm a little afraid to do any changes to my system.
but the temperature of my core duo is ~ 60°C, which is way too much. I have to lower it :shock:
I think I'll try it this evening.
btw: I use ubuntu since yesterday, so it may take a little longer for me :roll:

the-fallen
Administrator
Posts: 346
Joined: Wed 9. Jul 2008, 19:57

Re: Installation Guide

Post by the-fallen » Sun 31. Aug 2008, 09:16

Hey martini. Welcome :)

60 degrees celsius really is way too much for a idle Core.
Mine is idling at a temparature below 35 degrees (the sensor stops at 35 deg so I can not measure temps below that) even without PHC.
Maybe there is something else causing this temperature ?

martini
Posts: 3
Joined: Fri 29. Aug 2008, 15:32

Re: Installation Guide

Post by martini » Sun 31. Aug 2008, 10:56

hm, i don't know what else might be causing the high temperatures

the-fallen
Administrator
Posts: 346
Joined: Wed 9. Jul 2008, 19:57

Re: Installation Guide

Post by the-fallen » Wed 3. Sep 2008, 09:01

Try to find out if there isa daemon or process comsuming lots of CPU cycles ( you can use the commands "top" or "htop" for example).

martini
Posts: 3
Joined: Fri 29. Aug 2008, 15:32

Re: Installation Guide

Post by martini » Fri 5. Sep 2008, 10:36

I don't know what I did, but somehow I turned on the 3d- exalaration, which was off until yesterday. now I have a temperature of 48 while using firefox and amarok (music). when I watch a movie it jumps between 49 and 52 degrees. so it's much better now :D

but still, I'd like to lower it to 40 maybe

Post Reply