Page 1 of 1

VIDs do not change

Posted: Sun 15. Mar 2009, 00:14
by Daniel_le_Rouge
Hi!

I installed PHC tool sucessfully, so that I can read out the VID values and installed the GUI as well.

But when I want to change the values, nothing happens. The real values won't change even when it is just one unit (see attached screenshot).

What can I do to configure it correctly?

Thanks! Daniel

PS: It's an Intel Core 2 processor in a Fujitsu-Siemens Amilo Pi 2530 notebook.

Re: VIDs do not change

Posted: Wed 18. Mar 2009, 12:02
by the-fallen
Hmm,

did you tried only changing the VID of the lowest frequency?

If you change VIDs for other frequencies, too and then change to this frequency manually what happens then?

You are not able to set a lower VID than the lowest default one on a Core2 CPU. Its somehow hardware-fixed.
Maybe/hopefully you are just irritated by that and did not tried to set VIDs for higher frequencies.

Re: VIDs do not change

Posted: Wed 18. Mar 2009, 18:36
by Daniel_le_Rouge
Hi!

Thanks for your answer! I have only changed the VID of the lowest frequency which didn't work out.

Now I tried it for the other frequencies (my notebook has only 1500 Mhz and 1000 Mhz). It worked without any problem. Seems that you're right and the default VID of the lowest frequency fixes the minimum of the VID for the others.

Thanks again for your help. It doesn't solve my saving power problem, but at least I can use the 1500 Mhz without critical temperature error after some minutes.

Daniel

Re: VIDs do not change

Posted: Thu 19. Mar 2009, 10:57
by the-fallen
Yeah great that it worked.

But it is strange that there are only two speeds...


What processor is installed in your Amilo ?

Re: VIDs do not change

Posted: Thu 19. Mar 2009, 15:35
by Daniel_le_Rouge
The device manager says that there are two Intel(R) Core(TM)2 Duo CPU T5250 @ 1.50GHz.

On Wikipedia I found the following information:

Model Number: Core 2 Duo T5250
sSpec Number: SLA9S (M0)
Frequency: 1500 MHz
L2-Cache: 2 MB
Front Side Bus: 667 MT/s
Mult: 9x
Voltage: 1.0375 - 1.3 V
TDP: 35 W
Socket: Socket P
Release Date: Q2 2007
Part Number(s): LF80537GF0212M
Release Price (USD): OEM

Is there a possibilty to add another frequency or is it hardware-fixed as well?

Thanks again!

Re: VIDs do not change

Posted: Thu 19. Mar 2009, 21:56
by the-fallen
Generally the Core2 Duo CPUs should be capable of taking any frequency between their min and max in steps of the base frequency. The FIDs are like the multipliers back in the time we had set the frequency with jumpers.

So yes, it should be able to set other frequencies.
It should also be possible to change the count of speed steps but I do not know where.

You said that you only got two frequencies ... thats strange. Normally Linux should show you 4 Steps like I had on my Core2 ....

Do you use the 9.04 developement release?
Because I currently have only 3 steps. Maybe they working on something.