Page 1 of 2


Posted: Fri 11. Jul 2008, 21:15
by the-fallen
In this thread we will try to collect generic troubles and give a solution.

No such device
Patching the module just went fine but when I try to read values from the sysfs - files I get "No such device" instead of values.

This problem is not caused by linux-phc. The kernel module acpi-cpufreq is checking your system to find out if it is SYSTEM_INTEL_MSR_CAPABLE or SYSTEM_IO_CAPABLE. We can only set values with linux-phc if your system is msr_capable. Systems not being msr_Capable are caused by cheap BIOS implementation by the vendor. Sometimes a BIOS update or a replacement DSDT-file solve this problem.

insmod: error inserting 'arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko': -1 Device or resource busy
Trying to load the module acpi-cpufreq on a system with an Intel centrino Mobile CPU results in that error

This problem occurs if another module for managing speedsteps is already loaded. In the very most cases it happens with systems with an Intel centrino Mobile CPU. Here the operating system decides to load speedstep-centrino instead of acpi-cpufreq.
You can blacklist the speedstep-centrino module to prevent it from loading. The kernel should load acpi-cpufreq then.
You can try it manually first by unloading speedstep-centrino (modprobe -r speedstep-centrino) and load the acpi-cpufreq module (modprobe acpi-cpufreq).

Re: Troubleshooting

Posted: Sat 30. May 2009, 17:07
by synonymy

When I cat phc_, I get 'No such device'

Everything went smoothly from the kernel compile to the offtree compile and it's installation. I have the phc files but get the error. Previously I have been able to use the testing version for the 2.6.27 kernel and achieve success through speedstep-centrino. Following this post I am going to go ahead and download that old 2.6.27 kernel and use it in that it works. I do wonder however if there will be a speedstep-centrino patch available in the future for a current kernel.

Thx for your time..

Re: Troubleshooting

Posted: Sat 30. May 2009, 20:36
by the-fallen
Your problem is reported by others, too. Very few times but it is reported...

The problem is that ACPI decides that your system is (for what reason ever) is not capable of some needed abilities. This may be caused by a poor BIOS software implementation or something else.

Newer versions of the speedstep-centrino will only be available if there is someone willing to take care about the patches and port them to newer versions and test them.

Re: Troubleshooting

Posted: Fri 2. Oct 2009, 05:59
by rockharder
I use ThinkPad SL400 with T6570.
When I use "modprobe -r acpi-cpufreq", the reply is
FATAL: Module cpufreq_stats not found.
FATAL: Error running remove command for acpi_cpufreq

When I use "modprobe -r speedstep-centrino" there is no reply. But "modprobe acpi-cpufreq" gives me:
FATAL: Error inserting phc_intel (/lib/modules/2.6.29-sabayon/kernel/arch/x86/kernel/cpu/cpufreq/phc-intel.ko): Device or resource busy
FATAL: Module acpi_cpufreq not found.
FATAL: Error running install command for acpi_cpufreq

When I use lsmod, there is nothing relate to acpi-cpufreq. What did I do wrong?
Module Size Used by
snd_seq_dummy 1576 0
snd_seq_oss 23096 0
snd_seq_midi_event 4088 1 snd_seq_oss
snd_seq 35148 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 29192 0
snd_mixer_oss 10704 1 snd_pcm_oss
ipv6 210728 18
nvidia 9531156 31
snd_hda_codec_conexant 13984 1
snd_hda_intel 17308 1
snd_hda_codec 43460 2 snd_hda_codec_conexant,snd_hda_intel
snd_usb_audio 48744 3
ath5k 92088 0
snd_usb_lib 10304 1 snd_usb_audio
snd_rawmidi 14372 1 snd_usb_lib
snd_pcm 49408 4 snd_pcm_oss,snd_hda_intel,snd_hda_codec,snd_usb_audio
mac80211 123340 1 ath5k
snd_seq_device 4416 4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_timer 13908 2 snd_seq,snd_pcm
snd_hwdep 5028 2 snd_hda_codec,snd_usb_audio
snd 36748 21 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_rawmidi,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
sdhci_pci 5072 0
sdhci 12224 1 sdhci_pci
cfg80211 27860 2 ath5k,mac80211
mmc_core 34832 1 sdhci
r8169 23472 0
ricoh_mmc 2740 0
snd_page_alloc 6372 2 snd_hda_intel,snd_pcm
intel_agp 18252 0
i2c_core 14568 1 nvidia
pcspkr 1584 0
iTCO_wdt 7064 0
serio_raw 3728 0
iTCO_vendor_support 1864 1 iTCO_wdt
video 13504 5
output 1680 1 video
battery 8124 0
ac 3128 0
led_class 2532 2 ath5k,sdhci
joydev 7556 0
nvram 4724 0
tg3 94284 0
e1000 103212 0
dm_bbr 9296 0
sl811_hcd 9140 0
uhci_hcd 19060 0
ehci_hcd 30020 0
sx8 13148 0
scsi_wait_scan 1004 0
b1 20336 0
kernelcapi 28676 1 b1

Re: Troubleshooting

Posted: Fri 2. Oct 2009, 15:37
by the-fallen
PHC-Intel (wich is "only" a patched version of acpi-cpufreq) will not load if there is another cpufreq-driver loaded. You/we should find out why you can not unload acpi-cpufreq.

Please tell us more about your system (Distribution, what kernel (own or stock kernel), etc) and what is the last output from dmesg after you tried to run modprobe -r acpi-cpufreq (only the last significant lines - please do not post ALL of the output ;) )

Re: Troubleshooting

Posted: Sat 3. Oct 2009, 05:24
by rockharder
I am using Sabayon 4.2 which is derived from Gentoo. The kernel is 2.6.29

Re: Troubleshooting

Posted: Mon 5. Oct 2009, 20:16
by the-fallen
and the dmesg output ?

Re: Troubleshooting

Posted: Tue 6. Oct 2009, 03:07
by rockharder
dmesg |grep acpi
[ 17.556369] thinkpad_acpi: Not yet supported ThinkPad detected!
[ 17.673846] acpi device:23: registered as cooling_device2

dmesg |grep ACPI
[ 1.016006] ACPI: Power Button (FF) [PWRF]
[ 1.020011] ACPI: Sleep Button (CM) [SLPB]
[ 1.020338] ACPI: EC: non-query interrupt received, switching to interrupt mode
[ 1.025333] ACPI: Lid Switch [LID]
[ 1.025841] ACPI Warning (tbutils-0242): Incorrect checksum in table [SSDT] - 52, should be E1 [20081204]
[ 1.025846] ACPI: SSDT 7FFC67C0, 0244 (r1 PmRef TP-6A 180 INTL 20051117)
[ 1.026314] ACPI: SSDT 7FFC6AA0, 0765 (r1 PmRef Cpu0Cst 3001 INTL 20051117)
[ 1.027209] ACPI: CPU0 (power states: C1[C1] C2[C3])
[ 1.027250] processor ACPI_CPU:00: registered as cooling_device0
[ 1.027253] ACPI: Processor [P001] (supports 8 throttling states)
[ 1.027580] ACPI Warning (tbutils-0242): Incorrect checksum in table [SSDT] - 37, should be C7 [20081204]
[ 1.027585] ACPI: SSDT 7FFC66F0, 00C8 (r1 PmRef TP-6A 180 INTL 20051117)
[ 1.027998] ACPI: SSDT 7FFC6A10, 0085 (r1 PmRef Cpu1Cst 3000 INTL 20051117)
[ 1.028949] ACPI: CPU1 (power states: C1[C1] C2[C3])
[ 1.028989] processor ACPI_CPU:01: registered as cooling_device1
[ 1.028992] ACPI: Processor [P002] (supports 8 throttling states)
[ 1.034768] ACPI Warning (nspredef-0940): \_TZ_.THRM._PSL: Return Package type mismatch at index 0 - found Processor, expected Reference [20081204]
[ 1.034776] ACPI: Expecting a [Reference] package element, found type C
[ 1.034780] ACPI: Invalid passive threshold
[ 1.036230] ACPI: Thermal Zone [THRM] (37 C)
[ 5.083365] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
[ 5.093062] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 succeeded
[ 5.093066] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
[ 5.095979] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
[ 5.096237] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 succeeded
[ 5.096240] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
[ 5.447039] ata2.00: ACPI cmd ef/10:06:00:00:00:a0 succeeded
[ 5.447043] ata2.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
[ 5.456562] ata2.00: ACPI cmd ef/10:06:00:00:00:a0 succeeded
[ 5.456565] ata2.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
[ 17.516188] ACPI: AC Adapter [AC0] (on-line)
[ 17.655071] ACPI: Battery Slot [BAT0] (battery present)
[ 17.681168] ACPI: Video Device [VGA1] (multi-head: yes rom: no post: no)

I wonder if I should reload the kernel after the make. Looks like the kernel never change after recompile.

Re: Troubleshooting

Posted: Wed 7. Oct 2009, 19:22
by the-fallen
the dmesg output does not provide any information why your kernel is not loaded.

Please do not grep for something but "compare" the last lines before and after you tried to load the module and look if there is something that could be caused by the modprobe command.

Re: Troubleshooting

Posted: Thu 8. Oct 2009, 03:06
by rockharder
[ 37.935422] fbcondecor: switched decor state to 'on' on console 5
[ 46.597048] eth0: no IPv6 routers present
[ 56.811033] bluetooth-apple[7559]: segfault at 70180a90 ip b76f42cc sp bfec8410 error 4 in[b76cd000+80000]
[ 92.361842] r8169: eth0: link down
[ 98.582540] r8169: eth0: link up
[ 2330.658225] acpi_cpufreq: module is already loaded
above is dmesg after insmod acpi_cpufreq.ko command