Change font size
It is currently Fri 31. Oct 2014, 10:55


Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
PostPosted: Sat 2. Mar 2013, 12:23 

Joined: Thu 28. Feb 2013, 16:26
Posts: 1
Hello to all,I have istalled phc driver correctly but It doesn't work,there are no voltage control...I read that Pentium M cpus don't work well with phc on 3.x kernels, is that possible? O.o
On windows I have no problem undervolting the cpu...
Thank you very much

uname -r
3.7.9-2-ARCH

Code:
cat /proc/cpuinfo
processor   : 0
vendor_id   : GenuineIntel
cpu family   : 6
model      : 13
model name   : Intel(R) Pentium(R) M processor 1.80GHz
stepping   : 6
microcode   : 0x18
cpu MHz      : 1800.000
cache size   : 2048 KB
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 2
wp      : yes
flags      : fpu vme de pse tsc msr mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe bts est tm2
bogomips   : 3574.47
clflush size   : 64
cache_alignment   : 64
address sizes   : 32 bits physical, 32 bits virtual
power management:



Code:
# lsmod |grep phc
phc_intel              14512  1
mperf                   1024  1 phc_intel
processor              24552  2 phc_intel


Code:
# ls /sys/devices/system/cpu/cpu0/cpufreq/
affected_cpus               phc_rawcontrols                scaling_driver
bios_limit                  phc_version                    scaling_governor
cpuinfo_max_freq            phc_vids                       scaling_max_freq
cpuinfo_min_freq            related_cpus                   scaling_min_freq
cpuinfo_transition_latency  scaling_available_frequencies  scaling_setspeed
phc_default_rawcontrols     scaling_available_governors
phc_default_vids            scaling_cur_freq


Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/*
0
1800000
1800000
600000
10000
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_default_rawcontrols: No such device
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_default_vids: No such device
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_rawcontrols: No such device
0.3.199-2
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_vids: No such device
0
1800000 1600000 1400000 1200000 1000000 800000 600000
conservative ondemand performance
1600000
acpi-cpufreq
conservative
1800000
600000
<unsupported>


Top
 Profile  
 
PostPosted: Sat 4. May 2013, 02:40 

Joined: Sat 4. May 2013, 02:18
Posts: 2
I am having the exact same problem on Debian Squeeze, both with a Debian stock kernel (3.2, backported to Squeeze) and a 3.9 kernel that I compiled today. - I assume that some people have been successful with 3.x kernels. - It would be extremely helpful to hear from someone who made it work: which kernel, how they buildt the module etc.. I've been relying on linux-phc for years, it has been a great help, but now, for me at least, it seems to stop working at kernel version 2.6.39 . I've been using the phc-intel-pack-rev8 and rev9 . Pentium M735.
:( :? :shock: :cry:


Top
 Profile  
 
PostPosted: Sun 5. May 2013, 19:36 

Joined: Wed 2. Mar 2011, 18:37
Posts: 54
Some previous kernel (3.0?) changed the way this CPU (and other single core processors) are handled so phc does not work anymore for those. If you apply https://patchwork.kernel.org/patch/786962/ and https://patchwork.kernel.org/patch/106696/ it should work again. However, I never tried it by myself, just read about people who tried and lived long enough to report about it. ;)

lio


Top
 Profile  
 
PostPosted: Tue 7. May 2013, 21:24 

Joined: Sat 4. May 2013, 02:18
Posts: 2
Hi lio,
thanks very much for your comments, they put me on the right track to compile a working phc-enabled kernel 3.9.0 .
Though it is important to note that only https://patchwork.kernel.org/patch/106696/ should be applied wich amounts to replacing just one line in the file source-directory/drivers/acpi/processor_core.c, namely
Quote:
if (cpuid == -1)
with
Quote:
if ((cpuid == -1) && (num_possible_cpus() > 1))

After I had the patch numbers I found this message on the web (https://aur.archlinux.org/packages/phc-intel/?comments=all):
Quote:
Comment by sh__ 2011-08-11 13:08
It seems kernel 3.0 has some issues with uniprocessor / single-core machines. This patch seems to be the culprit:
https://patchwork.kernel.org/patch/786962/
I got phc-intel working on Pentium M by patching the kernel with an old patch:
https://patchwork.kernel.org/patch/106696/

I found this still to be the correct recipe. :D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB® Forum Software © phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net