[solved] No rule to make target `dkms_mkdeb'.

If you have trouble with PHC you can ask and hope for help here.
Posts: 6
Joined: Mon 14. May 2012, 09:08
Location: Chiang Mai (Thailand)

Re: [solved] No rule to make target `dkms_mkdeb'.

Post by Thomas1965 » Tue 15. May 2012, 15:00

So I am back at Ubuntu,

I allways wrote to you about one System I change and answer back, only for the Desktop System,
later I showed up I have a second system to compare and train the changes as well.

So just for Information:
under WinXP with Right Mark
- Desktop 800 MHz = 42 C Degrees
- mobile 800 MHz = 34 C
under Ubuntu gen-PHC
- Desktop 1.000 MHz = 45 C
- mobile 800 MHz = 34 C
I didn't meassure with an powerconsumption tool now, but have here, possible tomorrow
I'm using /etc/rc.local and echo to the phc_controls interface,
I would not mind to use Terminal also to check if it works, when I get the commands to check functionally of PHC-Driver with Freq and VID easy.
The Temp I see with PSensor
check /sys/devises/system/cpu/cpu0/cpufreq/scaling_driver
I check both:
- Desktop: phc-k8
- Mobile: powernow-k8 (you are right - so I have to try installation there again until I see answer from you)
both starting linux is generic-phc

I was reading more other Posts like that one: http://www.linux-phc.org/forum/viewtopic.php?f=14&t=67
PHC on Ubuntu 9.04
just I was locking as similar at Desktop with 12.04 and mobile with 11.10 for the .config at /usr/src/linux-source-<version>/.config

Desktop: if it is helping you anyway or in my case ...

Code: Select all

# CPU Frequency scaling

# x86 CPU frequency scaling drivers
looks not different at the mobile configuration.

= = = = = =
As I wrote you by PM: Possible start page for PHC using

If you want to change your freq and also your freq/vid you need to check:
- your processor (what data to look for, how ?)
- your linux kernel version (how to look for)
(Here possible a List of cussessfull installation, like - as table
- AMD Athlon 64, 3000+ - Ubuntu 12.04 - phc-k8-_v0.4.4 - PHCTool 0.5.2-2 - freq () - VID() - Link to Thread ...
- AMD Athlon 64 mobile 3200+ - Ubuntu 11.10 -- phc-k8-_v0.4.4 - PHCTool 0.5.2-2 ...)

What you need to install before as software to use, we suggest, need to make the changes:
- dep package name and how to test, if not how to install

What to be able to use during installation:
- sudo gedit (where to type in)
- sudo visudo -f <filename> (used at terminal, after change with cd into folder containing the file to change)
- sudo su #become SuperUser #exit to go back user
- uname -r #to see kernel version

What you need to Download to prepare:
- Download for your linux-version 'phc-k8_vxxx' or 'phc-intel_vxxx' from Link
- Download PHCTool ... Link
-> PHCTool Version 5.2.2-2 from Description and releases or PHCTool V 5.0.2-2 direct
-> PHCTool Version 5.2.2-2 patched for AMD Athlon 64 from with Discription or Direct

Step 1: recompile
... similar to http://www.linux-phc.org/forum/viewtopic.php?f=14&t=67 or the one i used,
... http://linuxsolver.blogspot.com/2011/02 ... buntu.html ...
but with example:
Now we have to generate a debian package (AMD users with newer kernels might find troubles, in case leave a comment):

make dkms_mkdeb
including other options
Now we have to generate a debian package (AMD users with newer kernels might find troubles, in case leave a comment):

make dkms_mkdeb
(sudo) make dkms_install
[yours from upper post]

Step 2: Install PHCTool
first what need to check, like:
- is starting system ...<version>-gneric-phc ? - if not back to check problems and issues at Step 1!
after Install:
- use program 'Startup Applications' to set PHCTray into Tray automatic
- check in programm 'group and Users' for new group -phcusers' and that you are part of it
- check /etc/sudoers for '%phcusers ALL=(root) NOPASSWD:/<your path>/phctool/subphctool.sh' #should not ask password when start

Step 3: Using PHCTool and change freq and/or vid
first what need to check, like:
- is PHCTray starting ?
- is PHCTool starting ?
- are you getting VID freq inside PCHTool ?
if not, please back Step 2 check issures!

? Would that be worth to wrtie together ?
It doens't look like much people here anymore ...

User avatar
Posts: 44
Joined: Wed 23. Feb 2011, 18:30

Re: [solved] No rule to make target `dkms_mkdeb'.

Post by Docet » Wed 30. May 2012, 08:57

Have tried to give any feedback to guys who write guides? :P BTW I am the author of linuxsolver...

Anyway I don't have a bunch of testers and actually I don't have an AMD powered PC either, so I'm not able to test everything I write. Back to your troubles, I have already removed the symlink part as they seem not to work on Ubuntu (doh):

http://linuxsolver.blogspot.it/2012/03/ ... -1110.html

The dmks_mkdeb is useful if you manage to build a .deb package... it makes you able to reinstall phc driver (on the same machine) without compiling anything, so it is quite useful, don't you think? I think that the point is: can we make it available for k8 version too?

Take a look again at my guide if you think I need to make changes. Anyway keep in mind that ub-users want to cut and paste terminal lines, and a guy to answer their questions.



If you have still troubles with phctool I'm the right guy ^_^

Posts: 5
Joined: Fri 11. Jan 2013, 23:18

Re: [solved] No rule to make target `dkms_mkdeb'.

Post by droptop » Fri 11. Jan 2013, 23:32

Crap. Well, I was trying to make my own topic, but I kept running into General SQL ERROR [1364] (Field 'topic_last_poster_name' doesn't have a default value)

Here's what I wanted to post:
Running into a few stumbling blocks using the [url-http://linuxsolver.blogspot.com/2011/02 ... buntu.html]external tutorial[/url].

I have the last updates for 11.04 (kernel 2.6.38-16-generic compared to PHC's 2.6.36-11), and already have gtk2-engines-pixbuf, python-gtk2-dev, dkms and debhelper.

The first trip-up is the Intel driver. Extracting it to /tmp, entering the directory, I execute this (which exits with a debian/rules error)

Code: Select all

make dkms_mkdeb
exits error.
I can install the driver with this

Code: Select all

make install
Then next issue is the GUI. After running install.sh and binding the files to /usr/bin, running phctool in a terminal, sudo or not, results in nothing.

Scratching my head what went wrong. Perhaps its Ubuntu 11.04, or the aged Pentium M 715 processor inside?

User avatar
Posts: 180
Joined: Fri 18. Jul 2008, 11:25

Re: [solved] No rule to make target `dkms_mkdeb'.

Post by DavidG » Sat 12. Jan 2013, 00:23

droptop wrote:edit
Crap. Well, I was trying to make my own topic, but I kept running into General SQL ERROR [1364] (Field 'topic_last_poster_name' doesn't have a default value)
Thanks for noting, it should be fixed now. Just another leftover from the mysql4 to mysql5 transition. AFAIK all database tables and fields should be fixed now...
A bank is a place where they lend you an umbrella in fair weather and ask for it back when it begins to rain -- R. Frost

Posts: 5
Joined: Fri 11. Jan 2013, 23:18

Re: [solved] No rule to make target `dkms_mkdeb'.

Post by droptop » Sat 19. Jan 2013, 07:18

Thanks David. I'll make a new topic (or two) with this.

Post Reply