kernel 2.6.36-rc6 & Intel i3core processor [help needed]

If you have trouble with PHC you can ask and hope for help here.
Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
ryszardzonk
Posts: 19
Joined: Sat 2. Oct 2010, 14:27
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

kernel 2.6.36-rc6 & Intel i3core processor [help needed]

Post by ryszardzonk » Sat 2. Oct 2010, 14:40

Hello everyone,

I would love to us linux-PHC on my new machine possibly with newest kernel available as it has additional drm improvements for Interlake chipset. My question is however has the intel patch been ported to use with this new version or what steps do I need to perform to do so.

Thanks in advance,
rz

ryszardzonk
Posts: 19
Joined: Sat 2. Oct 2010, 14:27
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: kernel 2.6.36-rc6 & Intel i3core processor [help needed]

Post by ryszardzonk » Tue 5. Oct 2010, 21:46

I have followed instalation guide from this thread http://www.linux-phc.org/forum/viewtopic.php?f=8&t=8
Installed properly the test patch for version 2.6.36 from fallen http://www.linux-phc.org/forum/viewtopi ... 1202#p1202
and my results are as follow

Code: Select all

cat /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
0:22 0:21 0:20 0:19 0:18 0:17 0:16 0:15 0:14 0:13 0:12 0:11 0:10 0:9 

Code: Select all

./read_msr.py --availfids
MSRTOOL V0.2pre-3 started...

cpu0
Your PHC Version is < 0.4 - the available_fids interface is not supported
cpu1
Your PHC Version is < 0.4 - the available_fids interface is not supported
cpu2
Your PHC Version is < 0.4 - the available_fids interface is not supported
cpu3
Your PHC Version is < 0.4 - the available_fids interface is not supported

Code: Select all

./read_msr.py --readmsr
MSRTOOL V0.2pre-3 started...

[cpu0] [CURRENT] FID:0 HID:0 DID:0 VID:9 
[cpu0] [TARGET]  FID:0 HID:0 DID:0 VID:9 
[cpu0] [HIGHEST] FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu0] [LOWEST]  FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu0] [SLFM]    FID:22 VID:0 
[cpu0] [IDA]     FID:9 VID:0 
[cpu0] [CURRENTLY ACTIVE FEATURES] IDA:0 EIST:1

[cpu1] [CURRENT] FID:0 HID:0 DID:0 VID:9 
[cpu1] [TARGET]  FID:0 HID:0 DID:0 VID:9 
[cpu1] [HIGHEST] FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu1] [LOWEST]  FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu1] [SLFM]    FID:22 VID:0 
[cpu1] [IDA]     FID:9 VID:0 
[cpu1] [CURRENTLY ACTIVE FEATURES] IDA:0 EIST:1

[cpu2] [CURRENT] FID:0 HID:0 DID:0 VID:9 
[cpu2] [TARGET]  FID:0 HID:0 DID:0 VID:9 
[cpu2] [HIGHEST] FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu2] [LOWEST]  FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu2] [SLFM]    FID:22 VID:0 
[cpu2] [IDA]     FID:9 VID:0 
[cpu2] [CURRENTLY ACTIVE FEATURES] IDA:0 EIST:1

[cpu3] [CURRENT] FID:0 HID:0 DID:0 VID:9 
[cpu3] [TARGET]  FID:0 HID:0 DID:0 VID:9 
[cpu3] [HIGHEST] FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu3] [LOWEST]  FID:0 (HID:0 DID:0) VID:0 (not sure if they exist here)
[cpu3] [SLFM]    FID:22 VID:0 
[cpu3] [IDA]     FID:9 VID:0 
[cpu3] [CURRENTLY ACTIVE FEATURES] IDA:0 EIST:1
I can not seem to find what should be my next step... Please help

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable