Kernel oops with Athlon 64 X2 Black Edition

If you have trouble with PHC you can ask and hope for help here.
scosu
Posts: 4
Joined: Sun 28. Dec 2008, 13:34
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by scosu » Tue 28. Jul 2009, 14:08

i think i have the same cpu and it works great here with archlinux standard kernel and normal modules (not dkms).

Code: Select all

~ $ dmesg | grep phc
phc-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ processors (2 cpu cores) (version 2.20.00)
phc-k8:    6 : fid 0x12 (2600 MHz), vid 0xa
phc-k8:    8 : fid 0x10 (2400 MHz), vid 0xc
phc-k8:    10 : fid 0xe (2200 MHz), vid 0xe
phc-k8:    12 : fid 0xc (2000 MHz), vid 0x10
phc-k8:    14 : fid 0xa (1800 MHz), vid 0x10
phc-k8:    22 : fid 0x2 (1000 MHz), vid 0x12
phc-k8:    1 : fid 0x17 (3100 MHz), vid 0x8
phc-k8:    2 : fid 0x16 (3000 MHz), vid 0x9
phc-k8:    3 : fid 0x15 (2900 MHz), vid 0xb
phc-k8:    4 : fid 0x14 (2800 MHz), vid 0xc
phc-k8:    5 : fid 0x13 (2700 MHz), vid 0xd
phc-k8:    6 : fid 0x12 (2600 MHz), vid 0xe
phc-k8:    7 : fid 0x11 (2500 MHz), vid 0xf
phc-k8:    8 : fid 0x10 (2400 MHz), vid 0x11
phc-k8:    9 : fid 0xf (2300 MHz), vid 0x13
phc-k8:    10 : fid 0xe (2200 MHz), vid 0x16
phc-k8:    11 : fid 0xd (2100 MHz), vid 0x17
phc-k8:    12 : fid 0xc (2000 MHz), vid 0x19
phc-k8:    13 : fid 0xb (1900 MHz), vid 0x19
phc-k8:    14 : fid 0xa (1800 MHz), vid 0x1a
phc-k8:    15 : fid 0x9 (1700 MHz), vid 0x1a
phc-k8:    16 : fid 0x8 (1600 MHz), vid 0x1a
phc-k8:    17 : fid 0x7 (1500 MHz), vid 0x1a
phc-k8:    18 : fid 0x6 (1400 MHz), vid 0x1a
phc-k8:    19 : fid 0x5 (1300 MHz), vid 0x1a
phc-k8:    20 : fid 0x4 (1200 MHz), vid 0x1a
phc-k8:    21 : fid 0x3 (1100 MHz), vid 0x1a
phc-k8:    22 : fid 0x2 (1000 MHz), vid 0x1b
phc-k8: ph2 null fid transition 0x12
phc-k8:    1 : fid 0x17 (3100 MHz), vid 0x8
phc-k8:    2 : fid 0x16 (3000 MHz), vid 0x9
phc-k8:    3 : fid 0x15 (2900 MHz), vid 0xb
phc-k8:    4 : fid 0x14 (2800 MHz), vid 0xc
phc-k8:    5 : fid 0x13 (2700 MHz), vid 0xd
phc-k8:    6 : fid 0x12 (2600 MHz), vid 0xe
phc-k8:    7 : fid 0x11 (2500 MHz), vid 0xf
phc-k8:    8 : fid 0x10 (2400 MHz), vid 0x11
phc-k8:    9 : fid 0xf (2300 MHz), vid 0x13
phc-k8:    10 : fid 0xe (2200 MHz), vid 0x16
phc-k8:    11 : fid 0xd (2100 MHz), vid 0x17
phc-k8:    12 : fid 0xc (2000 MHz), vid 0x19
phc-k8:    13 : fid 0xb (1900 MHz), vid 0x19
phc-k8:    14 : fid 0xa (1800 MHz), vid 0x1a
phc-k8:    15 : fid 0x9 (1700 MHz), vid 0x1a
phc-k8:    16 : fid 0x8 (1600 MHz), vid 0x1a
phc-k8:    17 : fid 0x7 (1500 MHz), vid 0x1a
phc-k8:    18 : fid 0x6 (1400 MHz), vid 0x1a
phc-k8:    19 : fid 0x5 (1300 MHz), vid 0x1a
phc-k8:    20 : fid 0x4 (1200 MHz), vid 0x1a
phc-k8:    21 : fid 0x3 (1100 MHz), vid 0x1a
phc-k8:    22 : fid 0x2 (1000 MHz), vid 0x1b
under load:

Code: Select all

~ $ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 3100.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 6231.26
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 3100.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 6231.26
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
this is the control line:

Code: Select all

control_line="23:8 22:9 21:11 20:12 19:13 18:14 17:15 16:17 15:19 14:22 13:23 12:25 11:25 10:26 9:26 8:26 7:26 6:26 5:26 4:26 3:26 2:27"

echo "$control_line" > /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
echo "$control_line" > /sys/devices/system/cpu/cpu1/cpufreq/phc_controls
and the configuration of the module:

Code: Select all

options phc-k8 direct_transitions=1
options phc-k8 be_maxfid=24
Perhaps your bios/motherboard doesn't support exactly this cpu?... or some configuration in the kernel that make problems?

You could try this kernel configuration from arch linux for 64bit cpu:
http://repos.archlinux.org/viewvc.cgi/k ... iew=markup

jasmine
Posts: 7
Joined: Wed 5. Aug 2009, 20:49
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by jasmine » Wed 5. Aug 2009, 23:39

fusterjj wrote:Ahh...makes sense. OK so now I have this output:

Code: Select all

[25757.121716] phc-k8:    0 : fid 0x16 (3000 MHz), vid 0x9
[25757.121720] phc-k8:    2 : fid 0x14 (2800 MHz), vid 0x9
[25757.121721] phc-k8:    4 : fid 0x12 (2600 MHz), vid 0x9
[25757.121723] phc-k8:    6 : fid 0x10 (2400 MHz), vid 0xb
[25757.121724] phc-k8:    8 : fid 0xe (2200 MHz), vid 0xd
[25757.121725] phc-k8:    10 : fid 0xc (2000 MHz), vid 0xf
[25757.121726] phc-k8:    12 : fid 0xa (1800 MHz), vid 0x11
[25757.121728] phc-k8:    20 : fid 0x2 (1000 MHz), vid 0x12
But if I check some of the sysfs entries:

Code: Select all

root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_available_frequencies 
3000000 2800000 2600000 2400000 2200000 2000000 1800000 1000000 
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat cpuinfo_max_freq 
3000000
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_max_freq
2600000
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# echo 3000000 > scaling_max_freq 
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_max_freq 
2600000
As you see I'm unable to set the maximum scaling frequency to 3GHz, even though it's listed in "scaling_available_frequencies". I've tried the userspace governor and using scaling_setspeed as well. What could make that happen? I've done some searches and it seems like some people have had this issue when their laptop batteries are missing or their AC adapter is malfunctioning, but obviously this is a desktop machine...
Your answer may be very simple...

From Ubuntu forums on a similar topic "undervolting AMD Turion using cpupowerd"
Sometimes the Gnome-Power-Manager make troubles on cpu undervolting, so test to stop or kill the gnome-power-manager and try cpupowerd again.
So try that:

Code: Select all

$ killall gnome-power-manager
Also, another user reports:
Finally, I figure out one way, thanks to smax.
There is hal, addon process called 'hald-addon-cpufreq' which is started in hald. It doesn't let cpupowerd do its job. Once you kill that process and then run cpupowerd, it works like a charm.

My laptop used to run at 53-55C all the time and now its mostly running at 45C.
So if killing gnome-power-manager alone does not give you the cpuinfo_max_freq under high load, you can try this as well:

Code: Select all

$ sudo killall hald-addon-cpufreq
Hope that helps... :)

fusterjj
Posts: 10
Joined: Sat 18. Jul 2009, 07:18
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by fusterjj » Thu 6. Aug 2009, 04:12

Well, I killed gnome-power-manager and tried userspace with echo 3000000 > scaling_setspeed, and also the performance governor, but the same thing: stuck at 2600MHz.

Oh, and I don't seem to have a hald-addon-cpufreq running, or anything similar.

I'll have some more time this weekend to try some other things.

scosu: What does your phc_default_controls say? I am using an Asus M2N-E with the latest BIOS that is supposed to have support for this CPU. It does run at the 3GHz that I configured via multplier in the BIOS if I don't run any cpufreq driver. Do you have cool'n'quiet enabled in your BIOS?


Thanks all!

Joel

User avatar
DavidG
Posts: 180
Joined: Fri 18. Jul 2008, 11:25
Contact:

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by DavidG » Thu 6. Aug 2009, 10:02

I don't think it will help, but could you try with "modprobe phc-k8 be_maxfid=23 direct_transitions=1"?

Also, what kernel are you using? Because both cpuinfo_max_freq and scaling_max_freq are using the same entry and are updated at the same place, I really don't get it... Could you switch the governor to "performance" and then check /proc/cpuinfo for the frequency your processor is running at?

And could you please install "msr-tools" and post the content of:

Code: Select all

sudo modprobe msr; sleep 1s
sudo rdmsr 0xc0010042
A bank is a place where they lend you an umbrella in fair weather and ask for it back when it begins to rain -- R. Frost

fusterjj
Posts: 10
Joined: Sat 18. Jul 2009, 07:18
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by fusterjj » Fri 7. Aug 2009, 05:34

DavidG wrote:I don't think it will help, but could you try with "modprobe phc-k8 be_maxfid=23 direct_transitions=1"?
I will reboot with be_maxfid=23 tomorrow, I am using be_maxfid=22 at the moment.
DavidG wrote: Also, what kernel are you using? Because both cpuinfo_max_freq and scaling_max_freq are using the same entry and are updated at the same place, I really don't get it... Could you switch the governor to "performance" and then check /proc/cpuinfo for the frequency your processor is running at?
I compiled the kernel from the Ubuntu sources based on your directions, subsequently rebuilt with cpufreq_stats as a module.

Code: Select all

root@periphas:~# cat /proc/version
Linux version 2.6.28.9-phc002 (root@periphas) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #1 SMP Fri Jul 24 22:19:09 EDT 2009
I have since noticed that sometimes scaling_max_freq is the same as cpuinfo_max_freq, but then other times it is not. I have not yet identified the conditions under which it is different vs the same. I have never seen scaling_cur_freq at cpuinfo_max_freq though.

At the moment:

Code: Select all

root@periphas:~# cat /sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_max_freq 
3000000
root@periphas:~# cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq 
2600000
root@periphas:~# cat /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_frequencies 
3000000 2800000 2600000 2400000 2200000 2000000 1800000 1000000 

Code: Select all

root@periphas:~# echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
root@periphas:~# cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 2600.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 5223.36
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 2600.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips	: 5223.36
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

root@periphas:~# 
DavidG wrote:And could you please install "msr-tools" and post the content of:

Code: Select all

sudo modprobe msr; sleep 1s
sudo rdmsr 0xc0010042

Code: Select all

root@periphas:~# rdmsr 0xc0010042
31071212072a0802

jasmine
Posts: 7
Joined: Wed 5. Aug 2009, 20:49
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by jasmine » Fri 7. Aug 2009, 15:52

Hi David,

I've been playing with msr-tools a few days ago actually, and I'm flustered as to why it doesn't work as it's supposed to..
for instance
jas@evrx:/usr/src/src-2.6.30$ grep MSR_FIDVID arch/x86/kernel/cpu/cpufreq/powernow-k8.h
#define MSR_FIDVID_CTL 0xc0010041
#define MSR_FIDVID_STATUS 0xc0010042
root@evrx:/root/drivers/phc# rdmsr 0xc0010042
rdmsr:pread: Invalid argument
root@evrx:/root/drivers/phc# rdmsr 0xc0010041
rdmsr:pread: Invalid argument
root@evrx:/root/drivers/phc# rdmsr c0010042
0
root@evrx:/root/drivers/phc# rdmsr c0010041
0
Yet, my little python script reads /dev/cpu/0/msr just fine
Note: I have been doing some testing to add AMD64/Opteron/TurionMobile support to PHCTool: Vcc calculation, checking if direct_transitions is enabled and detecting if there are intermediate FIDs added manually to PHC interface from command line to avoid PHCTool crashing because 0.5.2-2 doesnt know define default VIDs for the manually-added intermediate FIDs, and also msr polling for target/current VID/FID in analysis tab, etc.. Got a bunch of stuff added and will post up a patch soon..

(This is an example output of the default FID:VID -> 0:30 on my Turion64 X2 TL-50)
root@evrx:/root/drivers/phc# ./test.py
--- MSR_FIDVID_STATUS ---
0
0
8
17
30
30
17
51
--- MSR_FIDVID_CTL ---
0
30
0
0
1
0
0
0
So why isn't rdmsr working? :lol:

Just a very basic python script:

Code: Select all

#!/usr/bin/env python

import os

MSR_FIDVID_CTL=int(0xc0010041)
MSR_FIDVID_STATUS=int(0xc0010042)

msrfile = os.open("/dev/cpu/0/msr", os.O_RDONLY);

os.lseek(msrfile, MSR_FIDVID_STATUS, 0);        ##jump to where current values lie
value = os.read(msrfile, 8)                     ##read 8 bytes

print "--- MSR_FIDVID_STATUS ---"
for v in value:
        print ord(v)

os.lseek(msrfile, MSR_FIDVID_CTL, 0);           ##jump to where target values lie
value = os.read(msrfile, 8)                     ##read 8 bytes

print "--- MSR_FIDVID_CTL ---"
for v in value:
        print ord(v)

os.close(msrfile)

User avatar
DavidG
Posts: 180
Joined: Fri 18. Jul 2008, 11:25
Contact:

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by DavidG » Fri 7. Aug 2009, 16:05

You are probably using 32-bit Linux, that's probably a debian bug then. See:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495445
A bank is a place where they lend you an umbrella in fair weather and ask for it back when it begins to rain -- R. Frost

jasmine
Posts: 7
Joined: Wed 5. Aug 2009, 20:49
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by jasmine » Fri 7. Aug 2009, 18:01

@David

Yes, I'm actually on 32-bit :oops: Though on Ubuntu, but same dpkg version of msr-tools (1.1.2-1)
Now I know, thanks a lot :)

User avatar
DavidG
Posts: 180
Joined: Fri 18. Jul 2008, 11:25
Contact:

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by DavidG » Fri 7. Aug 2009, 22:52

@fusterjj: Could you please build your kernel with "Enable cpufreq debugging" and add the following to the kernel-options: cpufreq.debug=7

That may give some insights on what is happening when "cpufreq_frequency_table_cpuinfo" is called after your new frequency is enabled...

fusterjj
Posts: 10
Joined: Sat 18. Jul 2009, 07:18
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Kernel oops with Athlon 64 X2 Black Edition

Post by fusterjj » Sun 9. Aug 2009, 00:05

OK I rebuilt with cpufreq debugging and changed be_maxfid to 23. direct_transitions is 1

After modprobe:

Code: Select all

[  390.711654] phc-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ processors (2 cpu cores) (version 2.20.00)
[  390.711659] cpufreq-core: trying to register driver phc-k8
[  390.711662] cpufreq-core: adding CPU 0
[  390.711726] phc-k8: be_maxfid = 0x17
[  390.711729] phc-k8: Using direct transitions
[  390.711732] powernow-k8:    0 : fid 0x17, vid 0x3f
[  390.711733] powernow-k8:    1 : fid 0x16, vid 0x3f
[  390.711735] powernow-k8:    2 : fid 0x15, vid 0x3f
[  390.711736] powernow-k8:    3 : fid 0x14, vid 0x3f
[  390.711737] powernow-k8:    4 : fid 0x13, vid 0x3f
[  390.711738] powernow-k8:    5 : fid 0x12, vid 0x9
[  390.711739] powernow-k8:    6 : fid 0x11, vid 0x9
[  390.711741] powernow-k8:    7 : fid 0x10, vid 0xb
[  390.711742] powernow-k8:    8 : fid 0xf, vid 0xb
[  390.711743] powernow-k8:    9 : fid 0xe, vid 0xd
[  390.711744] powernow-k8:    10 : fid 0xd, vid 0xd
[  390.711745] powernow-k8:    11 : fid 0xc, vid 0xf
[  390.711747] powernow-k8:    12 : fid 0xb, vid 0xf
[  390.711748] powernow-k8:    13 : fid 0xa, vid 0x11
[  390.711749] powernow-k8:    14 : fid 0x9, vid 0x11
[  390.711750] powernow-k8:    15 : fid 0x8, vid 0x11
[  390.711751] powernow-k8:    16 : fid 0x7, vid 0x11
[  390.711753] powernow-k8:    17 : fid 0x6, vid 0x11
[  390.711754] powernow-k8:    18 : fid 0x5, vid 0x11
[  390.711755] powernow-k8:    19 : fid 0x4, vid 0x11
[  390.711756] powernow-k8:    20 : fid 0x3, vid 0x11
[  390.711757] powernow-k8:    21 : fid 0x2, vid 0x12
[  390.711759] phc-k8:    5 : fid 0x12 (2600 MHz), vid 0x9
[  390.711761] phc-k8:    7 : fid 0x10 (2400 MHz), vid 0xb
[  390.711762] phc-k8:    9 : fid 0xe (2200 MHz), vid 0xd
[  390.711763] phc-k8:    11 : fid 0xc (2000 MHz), vid 0xf
[  390.711764] phc-k8:    13 : fid 0xa (1800 MHz), vid 0x11
[  390.711765] phc-k8:    21 : fid 0x2 (1000 MHz), vid 0x12
[  390.711770] powernow-k8: cpu0, init lo 0x916, hi 0x1
[  390.711771] powernow-k8: policy current frequency 3000000 kHz
[  390.711773] freq-table: table entry 0 is invalid, skipping
[  390.711774] freq-table: table entry 1 is invalid, skipping
[  390.711776] freq-table: table entry 2 is invalid, skipping
[  390.711777] freq-table: table entry 3 is invalid, skipping
[  390.711778] freq-table: table entry 4 is invalid, skipping
[  390.711779] freq-table: table entry 5: 2600000 kHz, 2322 index
[  390.711780] freq-table: table entry 6 is invalid, skipping
[  390.711782] freq-table: table entry 7: 2400000 kHz, 2832 index
[  390.711783] freq-table: table entry 8 is invalid, skipping
[  390.711784] freq-table: table entry 9: 2200000 kHz, 3342 index
[  390.711786] freq-table: table entry 10 is invalid, skipping
[  390.711787] freq-table: table entry 11: 2000000 kHz, 3852 index
[  390.711788] freq-table: table entry 12 is invalid, skipping
[  390.711789] freq-table: table entry 13: 1800000 kHz, 4362 index
[  390.711791] freq-table: table entry 14 is invalid, skipping
[  390.711792] freq-table: table entry 15 is invalid, skipping
[  390.711793] freq-table: table entry 16 is invalid, skipping
[  390.711794] freq-table: table entry 17 is invalid, skipping
[  390.711795] freq-table: table entry 18 is invalid, skipping
[  390.711797] freq-table: table entry 19 is invalid, skipping
[  390.711798] freq-table: table entry 20 is invalid, skipping
[  390.711799] freq-table: table entry 21: 1000000 kHz, 4610 index
[  390.711801] freq-table: setting show_table for cpu 0 to ffff8800b49a8000
[  390.711803] powernow-k8: cpu_init done, current fid 0x16, vid 0x9
[  390.711824] cpufreq-core: CPU 1 already managed, adding link
[  390.711828] cpufreq-core: setting new policy for CPU 0: 1000000 - 2600000 kHz
[  390.711831] freq-table: request for verification of policy (1000000 - 2600000 kHz) for cpu 0
[  390.711833] freq-table: verification lead to (1000000 - 2600000 kHz) for cpu 0
[  390.711835] freq-table: request for verification of policy (1000000 - 2600000 kHz) for cpu 0
[  390.711837] freq-table: verification lead to (1000000 - 2600000 kHz) for cpu 0
[  390.711838] cpufreq-core: new min and max freqs are 1000000 - 2600000 kHz
[  390.711840] cpufreq-core: governor switch
[  390.711841] cpufreq-core: __cpufreq_governor for CPU 0, event 1
[  390.711843] performance: setting to 2600000 kHz because of event 1
[  390.711844] cpufreq-core: target for CPU 0: 2600000 kHz, relation 1
[  390.711847] powernow-k8: targ: cpu 0, 2600000 kHz, min 1000000, max 2600000, relation 1
[  390.711849] powernow-k8: targ: curr fid 0x16, vid 0x9
[  390.711850] freq-table: request for target 2600000 kHz (relation: 1) for cpu 0
[  390.711852] freq-table: target is 5 (2600000 kHz, 2322)
[  390.711854] powernow-k8: cpu 0 transition to index 5
[  390.711855] powernow-k8: table matched fid 0x12, giving vid 0x9
[  390.711857] powernow-k8: cpu 0, changing to fid 0x12, vid 0x9
[  390.711858] cpufreq-core: notification 0 of frequency transition to 2600000 kHz
[  390.711863] cpufreq-core: notification 0 of frequency transition to 2600000 kHz
[  390.711866] powernow-k8: ph1 (cpu0): start, currfid 0x16, currvid 0x9, reqvid 0x9, rvo 0x2
[  390.711868] powernow-k8: ph1 maxvid=0x7
[  390.711869] powernow-k8: ph1: changing vid for rvo, req 0x8
[  390.711871] powernow-k8: writing vid 0x8, lo 0x10816, hi 0x1
[  390.711972] powernow-k8: ph1: changing vid for rvo, req 0x7
[  390.711973] powernow-k8: writing vid 0x7, lo 0x10716, hi 0x1
[  390.712075] powernow-k8: ph1 complete, currfid 0x16, currvid 0x7
[  390.712077] powernow-k8: writing fid 0x12, lo 0x10712, hi 0x190
[  390.712187] powernow-k8: ph2 complete, currfid 0x12, currvid 0x7
[  390.712189] powernow-k8: ph3 (cpu0): starting, currfid 0x12, currvid 0x7
[  390.712191] powernow-k8: writing vid 0x9, lo 0x10912, hi 0x1
[  390.712194] powernow-k8: ph3 complete, currfid 0x12, currvid 0x9
[  390.712197] powernow-k8: transitioned (cpu0): new fid 0x12, vid 0x9
[  390.712199] cpufreq-core: notification 1 of frequency transition to 2600000 kHz
[  390.712221] cpufreq-core: notification 1 of frequency transition to 2600000 kHz
[  390.712225] cpufreq-core: governor: change or update limits
[  390.712228] cpufreq-core: __cpufreq_governor for CPU 0, event 3
[  390.712231] performance: setting to 2600000 kHz because of event 3
[  390.712233] cpufreq-core: target for CPU 0: 2600000 kHz, relation 1
[  390.712236] powernow-k8: targ: cpu 0, 2600000 kHz, min 1000000, max 2600000, relation 1
[  390.712238] powernow-k8: targ: curr fid 0x12, vid 0x9
[  390.712241] freq-table: request for target 2600000 kHz (relation: 1) for cpu 0
[  390.712243] freq-table: target is 5 (2600000 kHz, 2322)
[  390.712245] powernow-k8: cpu 0 transition to index 5
[  390.712248] powernow-k8: table matched fid 0x12, giving vid 0x9
[  390.712250] powernow-k8: target matches current values (fid 0x12, vid 0x9)
[  390.712258] cpufreq-core: initialization complete
[  390.712261] cpufreq-core: adding CPU 1
[  390.712266] cpufreq-core: driver phc-k8 up and running
After setting phc_controls:

Code: Select all

echo "22:9 20:9 18:9 16:11 14:13 12:15 10:17 2:18" |sudo tee /sys/devices/system/cpu/cpu0/cpufreq/phc_controls
echo "22:9 20:9 18:9 16:11 14:13 12:15 10:17 2:18" |sudo tee /sys/devices/system/cpu/cpu1/cpufreq/phc_controls

Code: Select all

[  512.758270] freq-table: table entry 0 is invalid, skipping
[  512.758274] freq-table: table entry 1: 3000000 kHz, 2326 index
[  512.758276] freq-table: table entry 2 is invalid, skipping
[  512.758277] freq-table: table entry 3: 2800000 kHz, 2324 index
[  512.758279] freq-table: table entry 4 is invalid, skipping
[  512.758280] freq-table: table entry 5: 2600000 kHz, 2322 index
[  512.758282] freq-table: table entry 6 is invalid, skipping
[  512.758283] freq-table: table entry 7: 2400000 kHz, 2832 index
[  512.758285] freq-table: table entry 8 is invalid, skipping
[  512.758286] freq-table: table entry 9: 2200000 kHz, 3342 index
[  512.758290] phc-k8:    1 : fid 0x16 (3000 MHz), vid 0x9
[  512.758291] phc-k8:    3 : fid 0x14 (2800 MHz), vid 0x9
[  512.758292] phc-k8:    5 : fid 0x12 (2600 MHz), vid 0x9
[  512.758294] phc-k8:    7 : fid 0x10 (2400 MHz), vid 0xb
[  512.758295] phc-k8:    9 : fid 0xe (2200 MHz), vid 0xd
[  512.758296] phc-k8:    11 : fid 0xc (2000 MHz), vid 0xf
[  512.758298] phc-k8:    13 : fid 0xa (1800 MHz), vid 0x11
[  512.758299] phc-k8:    21 : fid 0x2 (1000 MHz), vid 0x12
[  512.763825] phc-k8:    1 : fid 0x16 (3000 MHz), vid 0x9
[  512.763828] phc-k8:    3 : fid 0x14 (2800 MHz), vid 0x9
[  512.763829] phc-k8:    5 : fid 0x12 (2600 MHz), vid 0x9
[  512.763831] phc-k8:    7 : fid 0x10 (2400 MHz), vid 0xb
[  512.763832] phc-k8:    9 : fid 0xe (2200 MHz), vid 0xd
[  512.763833] phc-k8:    11 : fid 0xc (2000 MHz), vid 0xf
[  512.763834] phc-k8:    13 : fid 0xa (1800 MHz), vid 0x11
[  512.763836] phc-k8:    21 : fid 0x2 (1000 MHz), vid 0x12

Code: Select all

joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat cpuinfo_max_freq 
3000000
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat scaling_max_freq
3000000
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat scaling_available_frequencies 
3000000 2800000 2600000 2400000 2200000 2000000 1800000 1000000 
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat scaling_governor 
performance
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat scaling_cur_freq 
2600000
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$ cat /proc/cpuinfo |grep MHz
cpu MHz		: 2600.000
cpu MHz		: 2600.000
joel@periphas:/sys/devices/system/cpu/cpu0/cpufreq$
echo ondemand > scaling_governor

Code: Select all

[ 3566.901056] cpufreq-core: setting new policy for CPU 0: 1000000 - 3000000 kHz
[ 3566.901060] freq-table: request for verification of policy (1000000 - 3000000 kHz) for cpu 0
[ 3566.901063] freq-table: verification lead to (1000000 - 3000000 kHz) for cpu 0
[ 3566.901067] freq-table: request for verification of policy (1000000 - 2600000 kHz) for cpu 0
[ 3566.901069] freq-table: verification lead to (1000000 - 2600000 kHz) for cpu 0
[ 3566.901071] cpufreq-core: new min and max freqs are 1000000 - 2600000 kHz
[ 3566.901072] cpufreq-core: governor switch
[ 3566.901074] cpufreq-core: __cpufreq_governor for CPU 0, event 2
[ 3566.901076] cpufreq-core: __cpufreq_governor for CPU 0, event 1
[ 3566.901103] cpufreq-core: governor: change or update limits
[ 3566.901105] cpufreq-core: __cpufreq_governor for CPU 0, event 3
[ 3566.916282] __ratelimit: 50 callbacks suppressed
[ 3566.916286] cpufreq-core: target for CPU 0: 1045652 kHz, relation 0
[ 3566.916290] powernow-k8: targ: cpu 0, 1045652 kHz, min 1000000, max 2600000, relation 0
[ 3566.916292] powernow-k8: targ: curr fid 0x12, vid 0x9
[ 3566.916294] freq-table: request for target 1045652 kHz (relation: 0) for cpu 0
[ 3566.916296] freq-table: target is 13 (1800000 kHz, 4362)
[ 3566.916298] powernow-k8: cpu 0 transition to index 13
[ 3566.916300] powernow-k8: table matched fid 0xa, giving vid 0x11
[ 3566.916301] powernow-k8: cpu 0, changing to fid 0xa, vid 0x11
[ 3566.916303] cpufreq-core: notification 0 of frequency transition to 1800000 kHz
[ 3566.916307] cpufreq-core: notification 0 of frequency transition to 1800000 kHz
[ 3575.316050] __ratelimit: 32 callbacks suppressed
[ 3575.316058] cpufreq-core: target for CPU 0: 2600000 kHz, relation 1
[ 3575.316067] powernow-k8: targ: cpu 0, 2600000 kHz, min 1000000, max 2600000, relation 1
[ 3575.316072] powernow-k8: targ: curr fid 0x2, vid 0x12
[ 3575.316077] freq-table: request for target 2600000 kHz (relation: 1) for cpu 0
[ 3575.316083] freq-table: target is 5 (2600000 kHz, 2322)
[ 3575.316087] powernow-k8: cpu 0 transition to index 5
[ 3575.316091] powernow-k8: table matched fid 0x12, giving vid 0x9
[ 3575.316095] powernow-k8: cpu 0, changing to fid 0x12, vid 0x9
[ 3575.316100] cpufreq-core: notification 0 of frequency transition to 2600000 kHz
[ 3575.316108] cpufreq-core: notification 0 of frequency transition to 2600000 kHz

Code: Select all

root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_available_frequencies 
3000000 2800000 2600000 2400000 2200000 2000000 1800000 1000000 
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat scaling_max_freq 
2600000
root@periphas:/sys/devices/system/cpu/cpu0/cpufreq# cat /proc/cpuinfo |grep MHz
cpu MHz		: 1000.000
cpu MHz		: 1000.000

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable