phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.19

Discuss about PHC here. For problems please use the PHC Help forum
lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by lio » Mon 9. Dec 2013, 00:59

Please have a look at e.g. http://www.linux-phc.org/forum/viewtopi ... 6846#p6846 or open a new thread regarding phc-k8. Here is phc-intel land. phc-k8 is not my terrain. ;)

ryszardzonk
Posts: 19
Joined: Sat 2. Oct 2010, 14:27

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by ryszardzonk » Mon 9. Dec 2013, 23:44

OMG. I dunno how did that happen. I meant to post it in the phc-k8 thread like I did in the past ;) Sorry for the confusion

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by lio » Mon 20. Jan 2014, 18:21

Just updated phc-intel for kernel 3.13.

teknohog
Posts: 6
Joined: Wed 10. Jun 2009, 10:42

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by teknohog » Tue 28. Jan 2014, 15:54

lio wrote:Just updated phc-intel for kernel 3.13.
0.4.0 patch to 3.13 fails to compile:

Code: Select all

drivers/cpufreq/acpi-cpufreq.c:1638:13: error: ‘acpi_cpufreq_verify’ undeclared here (not in a function)
  .verify  = acpi_cpufreq_verify,
             ^
drivers/cpufreq/acpi-cpufreq.c:1639:2: warning: initialization from incompatible pointer type [enabled by default]
  .target  = acpi_cpufreq_target,
  ^
drivers/cpufreq/acpi-cpufreq.c:1639:2: warning: (near initialization for ‘acpi_cpufreq_driver.target’) [enabled by default]

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by lio » Tue 28. Jan 2014, 22:09

teknohog wrote:0.4.0 patch to 3.13 fails to compile:
Thanks for the pointer. Please try phc-intel-pack-rev13.1 where I have fixed this stupid copy and paste bug.

teknohog
Posts: 6
Joined: Wed 10. Jun 2009, 10:42

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by teknohog » Wed 29. Jan 2014, 11:54

lio wrote:
teknohog wrote:0.4.0 patch to 3.13 fails to compile:
Thanks for the pointer. Please try phc-intel-pack-rev13.1 where I have fixed this stupid copy and paste bug.
Thanks, works fine now :)

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by lio » Mon 9. Jun 2014, 11:53

The package is now up to date with kernel 3.15.

lio

teknohog
Posts: 6
Joined: Wed 10. Jun 2009, 10:42

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by teknohog » Tue 10. Jun 2014, 11:04

lio wrote:The package is now up to date with kernel 3.15.
...or is it? ;)

Code: Select all

drivers/cpufreq/acpi-cpufreq.c: In function ‘acpi_cpufreq_target_deprecated’:
drivers/cpufreq/acpi-cpufreq.c:508:2: error: implicit declaration of function ‘cpufreq_notify_transition’ [-Werror=implicit-function-declaration]
  cpufreq_notify_transition(policy, &freqs, CPUFREQ_PRECHANGE);
  ^
  CC [M]  fs/nfs/callback_xdr.o
cc1: some warnings being treated as errors
distcc[8780] ERROR: compile drivers/cpufreq/acpi-cpufreq.c on localhost failed
Edit: this is the 0.4.0 patch for 3.15.

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by lio » Wed 11. Jun 2014, 00:05

Oops, I missed a change. :( Please give phc-intel-pack-rev15.1 a try..

teknohog
Posts: 6
Joined: Wed 10. Jun 2009, 10:42

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 3.

Post by teknohog » Wed 11. Jun 2014, 01:15

lio wrote:Oops, I missed a change. :( Please give phc-intel-pack-rev15.1 a try..
It's fine :)

Post Reply