phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.19

Discuss about PHC here. For problems please use the PHC Help forum
lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.17

Post by lio » Mon 13. Aug 2018, 13:21

phc-intel-pack-rev28 is out with an update for kernel 4.18.

tdpw
Posts: 3
Joined: Sat 24. Feb 2018, 17:29

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by tdpw » Thu 4. Oct 2018, 11:03

Hi,

I have two issues:

1. After hibnernation/suspend phc_vids setting are back to normal, I have to reapply them. Is there a way around thins?

2. On Debian Stretch I am unable to build the dkms-Package:

Code: Select all

tobias@notebook:~/Downloads/phc-intel-pack-rev28$ make dkms_mkdeb

Creating symlink /home/tobias/Downloads/phc-intel-pack-rev28/.dkms/phc-intel/0.3.2/source ->
                 /home/tobias/Downloads/phc-intel-pack-rev28/.dkms//usr/src//phc-intel-0.3.2

DKMS: add completed.
Using /etc/dkms/template-dkms-mkdeb
copying template...
modifying debian/README.Debian...
modifying debian/changelog...
modifying debian/compat...
modifying debian/control...
modifying debian/copyright...
modifying debian/dirs...
modifying debian/postinst...
modifying debian/prerm...
modifying debian/rules...
copying legacy postinstall template...
Copying source tree...
Building binary package... dpkg-source --before-build phc-intel-dkms-0.3.2
 fakeroot debian/rules clean
dh_clean: Compatibility levels before 9 are deprecated (level 7 in use)
 debian/rules build
 fakeroot debian/rules binary
dh_installdirs: Compatibility levels before 9 are deprecated (level 7 in use)
dh_strip: Compatibility levels before 9 are deprecated (level 7 in use)
dh_installdeb: Compatibility levels before 9 are deprecated (level 7 in use)
 dpkg-genbuildinfo --build=binary
 dpkg-genchanges --build=binary >../phc-intel-dkms_0.3.2_amd64.changes
dpkg-genchanges: info: binary-only upload (no source code included)
 dpkg-source --after-build phc-intel-dkms-0.3.2


DKMS: mkdeb completed.
Moving built files to /home/tobias/Downloads/phc-intel-pack-rev28/.dkms/phc-intel/0.3.2/deb...mv: cannot stat '/tmp/dkms.KdgORz/phc-intel-dkms_0.3.2_amd64.deb': No such file or directory
(bad exit status: 1)
Cleaning up temporary files...
mv: cannot stat '/home/tobias/Downloads/phc-intel-pack-rev28/.dkms/phc-intel/0.3.2/deb/*': No such file or directory
Makefile:232: recipe for target 'dkms_mkdeb' failed
make: *** [dkms_mkdeb] Error 1
Is there a way to fix this?

Thanks in advance!

facan
Posts: 2
Joined: Sun 7. Oct 2018, 09:29

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by facan » Sun 7. Oct 2018, 09:53

Hello,

I have a T2600 laptop, which is warm, firstly I clean it up and repasted, but didnt help it, so I found this program. I'm use Fedora 28 32 bit and I get this error message;

warning: "CONFIG_ENABLE_MUST_CHECK" redefined
  #define CONFIG_ENABLE_MUST_CHECK 1

If I do give the recommended parameter KERNELVERSION = 4.18.11 get the same error. Make install is apparently installed, but the phc driver is not activated, I can not retrieve the voltages. So what should i do?

Thanks

facan
Posts: 2
Joined: Sun 7. Oct 2018, 09:29

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by facan » Sun 7. Oct 2018, 10:33

make dkms_install add the following error:

cp: stat './inc//acpi-cpufreq.c' sikertelen: No such file or directory
make[1]: *** [Makefile:152: .prepare] Error 1
make[1]: Leaving directory '/var/lib/dkms/phc-intel/0.3.2/build'

So maybe the problem is the Fedora not use the acpi-cpufreq package, it uses scaling_cpu_freq instead?

Make dkms_mkrpm bulid the package should i installed?

I've installed it, now i see phc-vids i can change it, but it seems doesnt work, the temperatures still the same.

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by lio » Mon 8. Oct 2018, 12:30

tdpw wrote:
Thu 4. Oct 2018, 11:03
1. After hibnernation/suspend phc_vids setting are back to normal, I have to reapply them. Is there a way around thins?
Yes. The settings need to be applied on resume to work properly. Please search the forum for suspend or resume and you will find instructions for different systems to work with.
2. On Debian Stretch I am unable to build the dkms-Package:

Cleaning up temporary files...
mv: cannot stat '/home/tobias/Downloads/phc-intel-pack-rev28/.dkms/phc-intel/0.3.2/deb/*': Is there a way to fix this?
Yes. This one you can also find already answerd in this forum: http://www.linux-phc.org/forum/viewtopi ... 52&p=71933

lio

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by lio » Mon 8. Oct 2018, 12:44

facan wrote:
Sun 7. Oct 2018, 09:53
I'm use Fedora 28 32 bit and I get this error message;

warning: "CONFIG_ENABLE_MUST_CHECK" redefined
  #define CONFIG_ENABLE_MUST_CHECK 1
That's no error but only a warning. Things should still be building fine. You can post the complete build log.
Make install is apparently installed, but the phc driver is not activated, I can not retrieve the voltages
Does your system load the phc-intel modul after reboot? Depending on your configuration, the content of phc-intel.modprobe should be installed in your system somewhere. What's the output of lsmod?

lio

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Post by lio » Mon 8. Oct 2018, 12:47

facan wrote:
Sun 7. Oct 2018, 10:33
Make dkms_mkrpm bulid the package should i installed?
Yes.
I've installed it, now i see phc-vids i can change it, but it seems doesnt work, the temperatures still the same.
Well, did you actually change the phc-vids to lower ones? But at least we are going somewhere. If they are too low, your machine will hang. If that happens, you know the settings get applied, at last. ;)

lio

Post Reply