phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.18

Discuss about PHC here. For problems please use the PHC Help forum
danello
Posts: 5
Joined: Mon 6. Nov 2017, 19:03

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.13

Post by danello » Mon 6. Nov 2017, 19:48

Hi everybody, this is my first post... ;)

I'm an Ubuntu user and I'm going to try to undervolt a Clarksfield i7 (720QM), should I expect problems patching the latest kernels?

Thanks in advance

Danilo

danello
Posts: 5
Joined: Mon 6. Nov 2017, 19:03

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.14

Post by danello » Fri 8. Dec 2017, 13:28

Hi everybody, anybody got this?

Code: Select all

cat /sys/devices/system/cpu/cpu0/cpufreq/phc_fids 
0 0 0 0 0 0 0
phc_vids is ok and I can eventually change it, but I suppose that no frequency id means that I can't really apply a voltage to a certain multiplier, and some tests I did seem to confirm that.

I even searched on google, but nobody seems to have this issue...

Any idea?

Thanks in advance.

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by lio » Fri 23. Feb 2018, 18:02

danello wrote:
Fri 8. Dec 2017, 13:28

Code: Select all

cat /sys/devices/system/cpu/cpu0/cpufreq/phc_fids 
0 0 0 0 0 0 0
In another thread you said you own a Core i, however anything more recent than Core2 is not supported.

lio

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by lio » Fri 23. Feb 2018, 18:48

phc-intel-pack-rev25 is out with refreshed kernel files. You might want to read the warning attached to it.

tdpw
Posts: 3
Joined: Sat 24. Feb 2018, 17:29

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by tdpw » Sat 24. Feb 2018, 17:42

lio wrote:
Fri 23. Feb 2018, 18:48
phc-intel-pack-rev25 is out with refreshed kernel files. You might want to read the warning attached to it.
Hi Dirk,

Thanks for the update. And the warning.

It made me, however, stick to rev24 which I can use in current F27 still with kernel 4.13.3 and dkms package.

If I understood you correctly (?), I can not use the rev25 with dkms unless I install a 4.15.5 kernel or Fedora releases this particular version. This seems to be me a major drawback in terms of comfort.

I noticed, I can use the KERNELVERSION parameter with make, but that does not help me with dkms.

BTW (for other Fedora users), those packages are required to build the module:

Code: Select all

kernel-devel dkms rpm-build
I am grateful for ongoing support. Very much appreciated.

Tobias

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by lio » Wed 28. Feb 2018, 21:42

tdpw wrote:
Sat 24. Feb 2018, 17:42
It made me, however, stick to rev24 which I can use in current F27 still with kernel 4.13.3 and dkms package.

If I understood you correctly (?), I can not use the rev25 with dkms unless I install a 4.15.5 kernel or Fedora releases this particular version. This seems to be me a major drawback in terms of comfort.
Not quite. In your case, given kernel 4.13.3:
1. I'll quote from the warning: "Kernels with a patchlevel not mentiond in the update are not affected." -> This warning only applies to kernels 4.9.x, 4.14.x, 4.15.x where x is lower than the number mentioned in the note. So, with your kernel 4.13.3 (patchlevel=13, not mentioned) you can use rev25 right now.
2. Should Fedora upgrade to one of the mentioned kernels, e.g. 4.15.x, I guess they will likely switch to a more recent sublevel than x=4 (e.g. today kernel 4.15.7 was released…) so rev25 will continue to work for you.

Hope this clears things up. Please drop a message, if things are still cloudy.

lio

tdpw
Posts: 3
Joined: Sat 24. Feb 2018, 17:29

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by tdpw » Mon 5. Mar 2018, 05:23

Thanks for the reply. I my post there was a typo. As time of writing the kernel version in F27 was already 4.15.3 and is currently 4.15.4. Sorry for that. So currently I must build the module of rev25 manually as dkms is "broken".

EDIT: 4.15.6 just came as update into Fedora 27.

So I would appreciate if you would switch the sublevel, as you mentioned :)

Best,

Tobias

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.15

Post by lio » Tue 6. Mar 2018, 16:37

tdpw wrote:
Mon 5. Mar 2018, 05:23
EDIT: 4.15.6 just came as update into Fedora 27.

So I would appreciate if you would switch the sublevel, as you mentioned :)
In that case, phc-intel-pack-rev25 will work just fine. Nothing more to do.

lio

lio
Posts: 87
Joined: Wed 2. Mar 2011, 18:37

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.17

Post by lio » Mon 4. Jun 2018, 09:43

phc-intel-pack-rev27 is out with an update for kernel 4.17.

drake23
Posts: 3
Joined: Fri 27. May 2016, 14:56

Re: phc-intel 0.3.2 and 0.4.0 + dkms for kernel 2.6.27 to 4.17

Post by drake23 » Tue 26. Jun 2018, 20:44

Highly appreciated, many thanks :)!

Post Reply