Page 1 of 1

phctool won't run

Posted: Wed 11. May 2011, 10:50
by lockheed
I installed it from Arch's AUR and when I try to run it, I get

Code: Select all

$ phctool
  File "./phctool.py", line 14
    print "pyGTK missed"
                       ^
SyntaxError: invalid syntax
Needless to say, I have pyGTK installed.

Re: phctool won't run

Posted: Wed 11. May 2011, 12:50
by Docet
looks more like a syntax error (as comes out from the last line). Try to download and compile sources from forum, considering this help.

http://linuxsolver.blogspot.com/2011/02 ... buntu.html

Cheers

Re: phctool won't run

Posted: Mon 16. May 2011, 00:15
by lockheed
So I installed newest stable version from these forums and:

Code: Select all

$ sh phctool.sh 
  File "./phctool.py", line 14
    print "pyGTK missed"
                       ^
SyntaxError: invalid syntax
Apparently, it has something to python version installed in Arch, This distro goes for everything newest so unless you make your code up-to-date, Arch users won't be able to use it.

Re: phctool won't run

Posted: Mon 16. May 2011, 16:12
by Docet
Can you check your python version? I get the same issue if I use python >= 3... obviously it throws many other errors due to python3 diffs. You should run it with python2.... ot try to port it to python3 hehe :D

Cheers

Re: phctool won't run

Posted: Mon 16. May 2011, 16:14
by lockheed

Code: Select all

Python 3.2 (r32:88445, Apr 15 2011, 11:09:05) 
[GCC 4.5.2 20110127 (prerelease)] on linux2
I'm afraid I'm stuck with it cause it comes built in with Arch.

Re: phctool won't run

Posted: Mon 16. May 2011, 16:40
by Docet
you should have both versions of python, take a look...

anyway you might edit manually phctool.sh to launch "python2 phctool.py"

Cheers

Re: phctool won't run

Posted: Mon 16. May 2011, 16:45
by lockheed
Where would I put 'python2' in this file? I couldn't find 'python' to replace in there.