Search found 8 matches

by ibidem
Mon 9. Dec 2013, 06:50
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

Good news: No changes needed for 3.13 (at least through -rc3, and things _should_ be quieting down now.) What needs to happen before release? FYI, though, there's a new API available: This patch implements the new light weight prototype for target_index() routine It looks like this: int target_index...
by ibidem
Sat 12. Oct 2013, 07:49
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

There's a new beta driver in the test releases topic that should support 3.11 (and the most recently accepted changes for 3.12-rc1) Please try it and let me know if it works alright. 3.12 rc1: DKMS make.log for phc-k8-0.4.5b3 for kernel 3.12.0-rc1-tp-23 (i686) Fri Sep 20 21:37:24 PDT 2013 make[1]: ...
by ibidem
Sat 21. Sep 2013, 18:03
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

There's a new beta driver in the test releases topic that should support 3.11 (and the most recently accepted changes for 3.12-rc1) Please try it and let me know if it works alright. 3.12 rc1: DKMS make.log for phc-k8-0.4.5b3 for kernel 3.12.0-rc1-tp-23 (i686) Fri Sep 20 21:37:24 PDT 2013 make[1]: ...
by ibidem
Tue 6. Aug 2013, 04:26
Forum: PHC Help
Topic: PPAs for Quantal (Ubuntu 12.10)
Replies: 10
Views: 13910

Re: PPAs for Quantal (Ubuntu 12.10)

See https://bugs.launchpad.net/ubuntu/+sour ... bug/984288
(New kernel no longer needed; build and boot with the right options.)
by ibidem
Tue 6. Aug 2013, 04:20
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

Thanks, I had already started working on this. If I remember well, there have been other (trivial) changes to cpufreq/powernow-k8 as well that I would like to add before I'm releasing phc-k8 0.4.5. May I add you to my list of testers...? ;) If you wish that will be fine, but I don't have a really g...
by ibidem
Thu 1. Aug 2013, 07:20
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

And a proper patch. (Although it's a git patch, the repo is based on the 0.4.5b2 tarball) I can't attach it, so I'm copy/pasting. commit 725d95ba950a93edfcc85a3e2ca9eb25e1e164ee Author: Isaac Dunham <idunham@lavabit.com> Date: Wed Jul 31 22:10:41 2013 -0700 Proper fix for 3.11 diff --git a/phc-k8.c ...
by ibidem
Thu 1. Aug 2013, 06:06
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Re: Attempting to use with 3.11

OK, "index" became "driver_data".
Dirty way to fix is:

Code: Select all

sed -e 's/\.index/.driver_data/g' -i phc-k8.c
But that's not the right way, I know.
by ibidem
Thu 1. Aug 2013, 05:49
Forum: PHC Help
Topic: Attempting to use with 3.11
Replies: 13
Views: 18006

Attempting to use with 3.11

Since I've got an AMD-based laptop, I would like to try out dpm (the new Radeon dynamic power management, which can really lower power use). This requires kernel 3.11. But here's what I get: make -C /lib/modules/3.11.0-rc3-tp-24/build SUBDIRS=/root/phc-k8_v0.4.5b2 phc-k8.ko make[1]: Entering directo...